We're currently aware of the service interruption with Cloudflare
Resolved
Nov 18 at 04:20pm CET
The Cloudflare outage has been resolved and all our systems are back online and functioning normally. Thank you for your patience during this disruption.
Affected services
Created
Nov 18 at 01:18pm CET
We are affected by a wider Cloudflare outage, which our systems as well as many web application systems rely on. We're monitoring the situation closely and will update you as soon as we are notified of a fix by Cloudflare, and service is restored. We apologize for the inconvenience.
https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Affected services